Tech Edge WBO2 Forum Forum Index Tech Edge WBO2 Forum
For Tech Edge Wideband O2 Equipment
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Display brightness stopped responding

 
Post new topic   Reply to topic    Tech Edge WBO2 Forum Forum Index -> LD2
View previous topic :: View next topic  
Author Message
Rod S
Newbie
Newbie


Joined: 30 Nov 2008
Posts: 9

PostPosted: Sun Nov 30, 2008 8:17 am    Post subject: Display brightness stopped responding Reply with quote

I've just built two of these, I haven't finished building the 2Y1 controllers so wanted to test the displays first on the emulator (in the WButil programme).

I got the "crc" error on the display (both of them) but saw in another thread that upgrading the firmware sorts this.

It was 0135 on the CPUs as supplied and the latest on the website was 0138 so I updated it.

Displays now work perfectly on the emulator BUT the brightness no longer responds to changes in ambient light !!!!!!

It did respond to covering the photocell before, now it's just maximum brightness all the time.

The website only seems to have the latest firmware so I can't revert back to prove it but I'm 99.9% certain it was the upgrade that did it.

EDIT - I've just tested them again and there is some response, it just seems to be much slower and nowhere near as much of a change as before (doesn't go nearly as dim as before). Or I'm just imagining it Sad
Back to top
View user's profile Send private message
Thomas
Expert
Expert


Joined: 03 Aug 2008
Posts: 364
Location: Germany

PostPosted: Sun Nov 30, 2008 5:28 pm    Post subject: Reply with quote

Hi,
I just wonder that your LD wasn't delivered with the latest firmware on it? However: Til now I build 2 LD02, and I can confirm what you noticed: The "brightness range" seems rather small, but under real conditions it seems to work perfect in my eyes.
However...you simply can modify these values in the actual FW using the terminal of "wbutil":
Enable "config" mode (keeping button pressed when powered up).
Go to the terminal, schoose "execute from file" and select a *.txt file in wich you have typed the following table:

s3080
s3140
s3238
s3330
s3428
s3520
s3618
s3710
s3810
w

The values 30....38 mean the different ambient light conditions, measured by the LDR, the right two figures (80, 40, 38 etc) are the corresponding brightness values. This list is the default configuration of the latest firmware. Just give it a try.

Good luck!
Thomas
Back to top
View user's profile Send private message
Kengopro
Newbie
Newbie


Joined: 16 Jun 2016
Posts: 2

PostPosted: Thu Jun 16, 2016 5:02 am    Post subject: Reply with quote

This is beyond my knowledge so that I have enough.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Tech Edge WBO2 Forum Forum Index -> LD2 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group